Пример настройки роутеров MikroTik при FTTB-подключении к провайдеру

Латвийский производитель сетевого оборудования
Ответить
Аватара пользователя
alexpolig
Сообщения: 1
Зарегистрирован: 12 май 2018, 04:10

Пример настройки роутеров MikroTik при FTTB-подключении к провайдеру

Сообщение alexpolig » 08 янв 2018, 19:46

Описание касается только части настройки роутера для просмотра IPTV от Ростелекома.

Исходные данные:
  • тип подключения - FTTB (витая пара в квартиру);
  • доступ к Интернет - PPPoE (авторизация с логином и паролем).
Внимание!
Перед проведением любых манипуляций с роутером Mikrotik обязательно делать резервную копию своей конфигурации. Для этого нужно перейти на вкладку Files, выбрать Backup, ввести название архива и сохранить его на компьютере (например, перетащить на Рабочий стол). При возникновении проблем это позволит вернуться в исходное состояние: просто перетащить файл архива обратно в папку Files, выбрать его и нажать кнопку Restore.
Подразумеваю, что вы уже настроили себе конфигурацию роутера для работы в Интернет и знаете что такое winbox. В большинстве случаев у вас стандартная конфигурация: в первый интерфейс - ether1 подключен кабель витая пара от провайдера, остальные интерфейсы локальной сети (ether2-ether5) и WiFi (wlan1) объединены в бридж - bridge1-LAN.

Перед настройкой нужно загрузить с сайта mikrotik.com пакет multicast-xxxxxxx.npk для своего роутера и установить его (зайдите на роутер по winbox и перетащите файл multicast-xxxxxxx.npk в папку Files, затем перезагрузите роутер), только если вы не сделали этого ранее.

Переходим к настройке, ее можно сделать разными способами: вручную и с помощью терминала. Последнний способ мне кажется будет проще, его и опишу (на картинках покажу, как это будет выглядеть после выполнения команд).
  1. Заходим в роутер по winbox и запускаем New Terminal.
  2. Создаем новый параметр, для чего набираем в терминале:

    Код: Выделить всё

    /ip dhcp-client option
    add code=60 name=classid value="'sml723x-rt'"
    Изображение
  3. Создаем новое подключение DCHP Client на интерфейсе ether1

    Код: Выделить всё

    /ip dhcp-client
    add add-default-route=no dhcp-options=classid disabled=no interface=ether1 use-peer-dns=no use-peer-ntp=no
  4. Теперь переходим в раздел IP - DCHP Client, открываем наше новое соединение двойным шелчком и на вкладке Status запоминаем ip-адрес Gateway (например, 11.283.89.193), он нам нужен:

    Изображение
  5. Создаем маршрут для подключения IPTV, в качестве gateway указываем наш 11.283.89.193

    Код: Выделить всё

    /ip route
    dst-address=10.0.0.0/8 gateway=11.283.89.193 disabled=no distance=1
    Изображение
  6. Выясняем адрес приватного sdp-сервера, для чего:
    1. Отключаем pppoe-соединение, для чего переходим на вкладку PPP, выбираем наше pppoe-соединение и жмем крестик;
    2. Переходим в раздел IP - DCHP Client, открываем наше новое соединение двойным шелчком, ставим галку в окне напротив Use Peer DNS и делаем его соединением по умолчанию - в окне Add Defaul Route в выпадающем списке выбираем Yes, жмем Apply, закрываем окно.
    3. В терминале набираем команду:

      Код: Выделить всё

      ping sdp.svc.iptv.rt.ru
      и видим (записываем) адрес приватного SDP-сервера 10.хх.хх.хх
    Далее возвращаем все в исходное: в раздел IP - DCHP Client, открываем наше новое соединение двойным шелчком, убираем галку в окне напротив Use Peer DNS, в окне Add Defaul Route в выпадающем списке выбираем No, жмем Apply, закрываем окно. Включаем pppoe-соединение: переходим на вкладку PPP, выбираем наше pppoe-соединение жмем галку.
  7. Теперь настраиваем IGMP Proxy:

    Код: Выделить всё

    /routing igmp-proxy
    set query-interval=10s query-response-interval=1s quick-leave=yes
    /routing igmp-proxy interface
    add alternative-subnets=10.0.0.0/8 interface=ether1 upstream=yes
    add interface=bridge1-LAN
    Изображение
  8. Добавим правила в Firewall для трансляции мультикаст-потоков:

    Код: Выделить всё

    /ip firewall filter
    add action=accept chain=input protocol=igmp
    add action=accept chain=input dst-port=2020 protocol=udp
    не забываем потом на вкладке IP - Firewall вручную поднять эти правила выше запрещающих

После выполнения вышеперечисленных действий на портах ether2-ether5 и wlan1 есть интернет и мультикаст. Настройка закончена.
Но, поскольку в микротике не реализован ipmp snooping, настоятельно рекомендую обрубать в бридже мультикаст там, где он не нужен.

Например, обрубаем его на WiFi:

Код: Выделить всё

/interface bridge filter
add action=drop chain=output mac-protocol=ip out-interface=wlan1 packet-type=multicast
или везде, кроме 2-го порта:

Код: Выделить всё

/interface bridge filter
add action=drop chain=output mac-protocol=ip out-interface=!ether2 packet-type=multicast
ЗЫ: Хотя, лично у меня показывает и по WiFi, нужно только в настройках интерфейса wlan1 выставить в multicast-helper - full

Ответить